What browsers does Drift support?

Updated a month ago ​by Matt Bilotti

The browsers that the Drift chat widget supports (the chat bubble that you put on your website) are...

  • Chrome (Latest)
  • Safari (Latest)
  • Firefox (Latest)
  • Edge (Latest)
  • Internet Explorer (IE) 11

If your visitor or customer is using a different browser, Drift will be hidden automatically.

When you log into Drift (app.drift.com), these are the browsers that we support...

  • Chrome (Latest) - This is the browser we optimize the entire Drift experience for
  • Safari (Latest)
  • Firefox (Latest)

If you try to login with a different browser such as Internet Explorer, we can't promise an optimal experience 🙃, so we highly suggest using one of the above browsers.


Was this article helpful?


Can’t find what you’re looking for?

Talk To Us